xStarter localization issues

User avatar
Alex
Site Admin
Posts: 339
Joined: Mon May 21, 2007 4:09 pm
Contact:

Re: xStarter localization issues

Postby Alex » Mon Jun 22, 2009 4:44 am

Done, new beta version available...

Janusz
Posts: 30
Joined: Sun Mar 01, 2009 1:32 pm
Location: Poland, Zabrze
Contact:

Re: xStarter localization issues

Postby Janusz » Mon Jun 22, 2009 6:25 pm

Thanks. Current beta build has almost perfectly localization support :) . All UI items are enabled to localization; translators can to test localizations of plugin resources, full Unicode support – my congratulation!
I actually finished Polish localization, so let me know when you will be ready to publish next official release of xStarter – I’ll send Polish files to you ;) .

Janusz
http://www.sisulizer.com - Three simple steps to localize

Janusz
Posts: 30
Joined: Sun Mar 01, 2009 1:32 pm
Location: Poland, Zabrze
Contact:

Re: xStarter localization issues

Postby Janusz » Mon Jun 22, 2009 6:35 pm

I wrote “almost perfectly” ;) in my previous post, because Web Pilot web interface is not fully localized. What do you think about localization of this UI part?
Seem to me that Web UI base on index.htm, section.htm, tasks.htm and operation.htm stored in Web subfolder. I suppose that all UI items (expect for “Please, select section to see tasks...” string) are read from application via some placeholders e.g. %Tasks% or %WebFields%. Is this possible to link these items to resources in language files (e.g. Polish.lng)?
Below is list of potential localized UI items:

index.htm file:
Please, select section to see tasks...
Sections

section.htm file:
Sections
Section:

tasks.htm file:
Back to sections (link)
Task:
Enable (link)
View (link)
Log (link)
Run (link)
Disable (link)
Task was enabled
Task was disabled
Back (link)

operation.htm file:
Back (link)


Best,
Janusz
http://www.sisulizer.com - Three simple steps to localize

User avatar
Alex
Site Admin
Posts: 339
Joined: Mon May 21, 2007 4:09 pm
Contact:

Re: xStarter localization issues

Postby Alex » Mon Jun 22, 2009 11:58 pm

Sorry, I think this part translation will wait for next version(s). I need to complete new version today, it can not wait anymore for a publishing.

Janusz
Posts: 30
Joined: Sun Mar 01, 2009 1:32 pm
Location: Poland, Zabrze
Contact:

Re: xStarter localization issues

Postby Janusz » Tue Jun 23, 2009 12:25 am

Hi Alex,

Sorry, I think this part translation will wait for next version(s).

No problem :D

I need to complete new version today, it can not wait anymore for a publishing.

OK. Here link to updated Polish language files:
http://grzybek.anet.pl/xStarter_PL.zip

Best,
Janusz
http://www.sisulizer.com - Three simple steps to localize

User avatar
Alex
Site Admin
Posts: 339
Joined: Mon May 21, 2007 4:09 pm
Contact:

Re: xStarter localization issues

Postby Alex » Tue Jun 23, 2009 12:27 am

Thanks a lot, I will include it.

Janusz
Posts: 30
Joined: Sun Mar 01, 2009 1:32 pm
Location: Poland, Zabrze
Contact:

Re: xStarter localization issues

Postby Janusz » Wed Jun 24, 2009 6:04 pm

Below is link to Polish language files updated to xStarter 1.9.3.73 build (SFTP actions):
http://grzybek.anet.pl/xStarter_PL.zip

Best regards,
Janusz
http://www.sisulizer.com - Three simple steps to localize


Return to “Suggestions”

Who is online

Users browsing this forum: No registered users and 1 guest